Transcript
Cisco Catalyst Blade Switch 3040 for FSC Command Reference Cisco IOS Release 12.2(52)SE September 2009
Americas Headquarters Cisco Systems, Inc. 170 West Tasman Drive San Jose, CA 95134-1706 USA http://www.cisco.com Tel: 408 526-4000 800 553-NETS (6387) Fax: 408 527-0883
Text Part Number: OL-10696-06
THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS. THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY. The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB’s public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California. NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED “AS IS” WITH ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE. IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. CCDE, CCENT, CCSI, Cisco Eos, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Lumin, Cisco Nexus, Cisco Nurse Connect, Cisco Pulse, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, and Flip Gift Card are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Fast Step, Follow Me Browsing, FormShare, GainMaker, GigaDrive, HomeLink, iLYNX, Internet Quotient, IOS, iPhone, iQuick Study, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MediaTone, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, Network Registrar, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, ScriptShare, SenderBase, SMARTnet, Spectrum Expert, StackWise, The Fastest Way to Increase Your Internet Quotient, TransPath, WebEx, and the WebEx logo are registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries. All other trademarks mentioned in this document or website are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (0908R) Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses in illustrative content is unintentional and coincidental. Cisco Catalyst Blade Switch 3040 for FSC Command Reference ©2006–2009 Cisco Systems, Inc. All rights reserved.
CONTENTS Preface
xix
Audience Purpose
xix xix
Conventions
xx
Related Publications
xx
Obtaining Documentation and Submitting a Service Request
CHAPTER
1
Using the Command-Line Interface
xxi
1-1
CLI Command Modes 1-1 User EXEC Mode 1-3 Privileged EXEC Mode 1-3 Global Configuration Mode 1-3 Interface Configuration Mode 1-4 config-vlan Mode 1-4 VLAN Configuration Mode 1-5 Line Configuration Mode 1-5
CHAPTER
2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands aaa accounting dot1x
2-1
aaa authentication dot1x
2-3
aaa authorization network action
2-1
2-5
2-6
archive download-sw archive tar
2-8
2-11
archive upload-sw
2-14
authentication command bounce-port ignore
2-16
authentication command disable-port ignore
2-17
authentication control-direction authentication event
2-18
2-20
authentication fallback authentication host-mode
2-24 2-26
authentication mac-move permit
2-28
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
iii
Contents
authentication open
2-30
authentication order
2-32
authentication periodic
2-34
authentication port-control authentication priority authentication timer
2-38 2-40
authentication violation auto qos voip
2-42
2-44
boot config-file
2-48
boot enable-break boot helper
2-49
2-50
boot helper-config-file boot manual
2-51
2-52
boot private-config-file boot system
2-55
channel-protocol cisp enable
2-53
2-54
channel-group
class
2-36
2-58
2-59
2-60
class-map clear dot1x
2-62 2-64
clear eap sessions
2-65
clear errdisable interface clear ipc
2-66
2-67
clear l2protocol-tunnel counters clear ip dhcp snooping clear lacp
2-68
2-69
2-71
clear mac address-table
2-72
clear mac address-table move update clear nmsp statistics clear pagp
2-73
2-74
2-75
clear port-security
2-76
clear spanning-tree counters
2-78
clear spanning-tree detected-protocols clear vmps statistics
2-79
2-80
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
iv
OL-10696-06
Contents
clear vtp counters
2-81
define interface-range delete
2-82
2-84
deny (IPv6 access-list configuration)
2-85
deny (MAC access-list configuration) dot1x
2-90
2-93
dot1x auth-fail max-attempts dot1x auth-fail vlan
2-95
2-97
dot1x control-direction
2-99
dot1x credentials (global configuration) dot1x critical (global configuration)
2-102
dot1x critical (interface configuration) dot1x default
2-107
dot1x supplicant force-multicast dot1x guest-vlan
2-109
dot1x host-mode
2-111
dot1x max-reauth-req dot1x pae
2-113 2-115
2-116
2-117
dot1x port-control
2-118
dot1x re-authenticate
2-120
dot1x reauthentication
2-121
dot1x test eapol-capable dot1x test timeout dot1x timeout
2-122
2-123
2-124
dot1x violation-mode duplex
2-108
2-112
dot1x mac-auth-bypass dot1x max-req
2-104
2-106
dot1x fallback
dot1x initialize
2-101
2-127
2-128
errdisable detect cause
2-130
errdisable detect cause small-frame errdisable recovery cause small-frame errdisable recovery
2-135
exception crashinfo
2-138
2-132 2-134
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
v
Contents
fallback profile flowcontrol
2-139
2-141
interface port-channel interface range interface vlan
2-145 2-147
ip access-group ip address
2-143
2-149
2-152
ip admission
2-154
ip admission name proxy http
2-155
ip device tracking maximum ip dhcp snooping
2-157
2-158
ip dhcp snooping binding
2-159
ip dhcp snooping database
2-161
ip dhcp snooping information option
2-163
ip dhcp snooping information option allow-untrusted ip dhcp snooping information option format remote-id ip dhcp snooping limit rate ip dhcp snooping trust
2-165 2-167
2-168
2-169
ip dhcp snooping verify
2-170
ip dhcp snooping vlan
2-171
ip dhcp snooping vlan information option format-type circuit-id string ip igmp filter
2-172
2-174
ip igmp max-groups ip igmp profile
2-176
2-178
ip igmp snooping
2-180
ip igmp snooping last-member-query-interval ip igmp snooping querier
2-184
ip igmp snooping report-suppression ip igmp snooping tcn
2-190
ip igmp snooping vlan immediate-leave ip igmp snooping vlan mrouter ip igmp snooping vlan static ip source binding
2-186
2-188
ip igmp snooping tcn flood
ip snap forwarding
2-182
2-191
2-192 2-194
2-196 2-197
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
vi
OL-10696-06
Contents
ip ssh
2-199
ip sticky-arp (global configuration)
2-201
ip sticky-arp (interface configuration) ip verify source
2-205
ipv6 access-list
2-207
ipv6 mld snooping
2-203
2-209
ipv6 mld snooping last-listener-query-count ipv6 mld snooping last-listener-query-interval
2-211 2-213
ipv6 mld snooping listener-message-suppression ipv6 mld snooping robustness-variable ipv6 mld snooping tcn
2-221
2-223
l2protocol-tunnel
2-225
l2protocol-tunnel cos lacp port-priority
2-228
2-229
lacp system-priority
2-231
location (global configuration)
2-233
location (interface configuration) link state group
logging file
2-235
2-237
link state track logging event
2-217
2-219
ipv6 mld snooping vlan ipv6 traffic-filter
2-239 2-240
2-241
mab request format attribute 32 mac access-group
2-243
2-245
mac access-list extended
2-247
mac address-table aging-time
2-249
mac address-table learning vlan
2-250
mac address-table move update
2-252
mac address-table notification mac address-table static
2-257
2-259
macro description macro global
2-254
2-256
mac address-table static drop macro apply
2-215
2-262
2-263
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
vii
Contents
macro global description macro name
2-265
2-266
match (access-map configuration)
2-268
match (class-map configuration) mdix auto mls qos
2-270
2-272 2-274
mls qos aggregate-policer mls qos cos
2-276
2-278
mls qos dscp-mutation mls qos map
2-280
2-282
mls qos queue-set output buffers
2-286
mls qos queue-set output threshold mls qos rewrite ip dscp
2-288
2-290
mls qos srr-queue input bandwidth mls qos srr-queue input buffers
2-292
2-294
mls qos srr-queue input cos-map
2-296
mls qos srr-queue input dscp-map
2-298
mls qos srr-queue input priority-queue
2-300
mls qos srr-queue input threshold
2-302
mls qos srr-queue output cos-map
2-304
mls qos srr-queue output dscp-map mls qos trust
2-306
2-308
mls qos vlan-based monitor session
2-310
2-311
mvr (global configuration) mvr (interface configuration) network-policy
2-316 2-319
2-322
network-policy profile (global configuration)
2-323
network-policy profile (network-policy configuration) nmsp
2-325
2-327
nmsp attachment suppress pagp learn-method pagp port-priority
2-329
2-330 2-332
permit (IPv6 access-list configuration) permit (MAC access-list configuration)
2-334 2-340
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
viii
OL-10696-06
Contents
police
2-343
police aggregate policy-map
2-345
2-347
port-channel load-balance priority-queue
2-350
2-352
private-vlan
2-354
private-vlan mapping queue-set
2-357
2-359
radius-server dead-criteria radius-server host remote-span
2-360
2-362
2-364
renew ip dhcp snooping database reserved-only
2-368
rmon collection stats sdm prefer
2-369
2-370
service password-recovery service-policy set setup
2-366
2-373
2-375
2-378 2-380
show access-lists
2-383
show archive status
2-386
show authentication
2-387
show auto qos
2-391
show boot
2-395
show cisp
2-397
show class-map
2-398
show controllers cpu-interface
2-399
show controllers ethernet-controller show controllers tcam
2-408
show controllers utilization show dot1q-tunnel show dot1x
2-401
2-410
2-412
2-413
show dtp
2-417
show eap
2-419
show env
2-422
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
ix
Contents
show errdisable detect
2-423
show errdisable flap-values show errdisable recovery show etherchannel
show idprom
2-427
2-429
show fallback profile show flowcontrol
2-425
2-432
2-434
2-436
show interfaces
2-438
show interfaces counters show inventory
2-446
2-449
show ip dhcp snooping
2-451
show ip dhcp snooping binding
2-452
show ip dhcp snooping database
2-454
show ip dhcp snooping statistics
2-456
show ip igmp profile
2-459
show ip igmp snooping
2-460
show ip igmp snooping groups show ip igmp snooping mrouter show ip igmp snooping querier show ip source binding show ip verify source show ipc
2-463 2-465 2-467
2-469 2-471
2-473
show ipv6 access-list show ipv6 mld snooping
2-477 2-479
show ipv6 mld snooping address
2-481
show ipv6 mld snooping mrouter
2-483
show ipv6 mld snooping querier show l2protocol-tunnel show lacp
2-485
2-487
2-490
show location
2-494
show link state group
2-497
show link state group
2-499
show mac access-group
2-501
show mac address-table
2-503
show mac address-table address
2-505
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
x
OL-10696-06
Contents
show mac address-table aging-time show mac address-table count
2-507
2-509
show mac address-table dynamic
2-511
show mac address-table interface
2-513
show mac address-table learning
2-515
show mac address-table move update show mac address-table notification show mac address-table static
2-523
2-525
show mls qos aggregate-policer show mls qos input-queue show mls qos interface show mls qos maps
2-529
2-533
show mls qos vlan show monitor
2-536
2-538
2-539
2-542
show mvr interface
2-544
show mvr members
2-546
show network-policy profile show nmsp
2-550
show pagp
2-553
show parser macro show policy-map
2-558 2-560
show sdm prefer
2-563
show spanning-tree
2-566
show storm-control
2-572
show system mtu show udld
2-548
2-555
show port-security
2-574
2-575
show version show vlan
2-526
2-527
show mls qos queue-set
show mvr
2-518
2-521
show mac address-table vlan show mls qos
2-516
2-578 2-580
show vlan access-map show vlan filter
2-586
2-587
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
xi
Contents
show vmps show vtp shutdown
2-588 2-590 2-595
shutdown vlan
2-596
small-frame violation rate
2-597
snmp-server enable traps snmp-server host
2-599
2-603
snmp trap mac-notification change spanning-tree backbonefast spanning-tree bpdufilter
2-609 2-610
spanning-tree bpduguard spanning-tree cost
2-607
2-612
2-614
spanning-tree etherchannel guard misconfig spanning-tree extend system-id spanning-tree guard
2-618
2-619
spanning-tree link-type
2-621
spanning-tree loopguard default spanning-tree mode
2-623
2-625
spanning-tree mst configuration spanning-tree mst cost
2-627
2-629
spanning-tree mst forward-time spanning-tree mst hello-time spanning-tree mst max-age
2-631 2-632
2-633
spanning-tree mst max-hops
2-634
spanning-tree mst port-priority
2-635
spanning-tree mst pre-standard spanning-tree mst priority spanning-tree mst root
2-637
2-638 2-639
spanning-tree port-priority
2-641
spanning-tree portfast (global configuration) spanning-tree portfast (interface configuration) spanning-tree transmit hold-count spanning-tree uplinkfast spanning-tree vlan speed
2-616
2-643 2-645
2-647
2-648
2-650
2-653
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
xii
OL-10696-06
Contents
srr-queue bandwidth limit
2-655
srr-queue bandwidth shape
2-657
srr-queue bandwidth share
2-659
storm-control switchport
2-661 2-664
switchport access
2-666
switchport autostate exclude switchport backup interface switchport block
2-668 2-670
2-674
switchport host
2-676
switchport mode
2-677
switchport mode private-vlan switchport nonegotiate
2-682
switchport port-security
2-684
2-680
switchport port-security aging switchport priority extend switchport private-vlan switchport protected switchport trunk
2-695
2-700
2-704
traceroute mac ip trust
2-709
udld
2-711
udld reset
2-693
2-702
traceroute mac
udld port
2-691
2-697
switchport voice vlan system mtu
2-689
2-707
2-713 2-715
vlan (global configuration)
2-716
vlan (VLAN configuration)
2-721
vlan access-map vlan database
2-722 2-724
vlan dot1q tag native vlan filter
2-725
2-726
vmps reconfirm (privileged EXEC)
2-728
vmps reconfirm (global configuration)
2-729
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
xiii
Contents
vmps retry
2-730
vmps server
2-731
vtp (global configuration)
2-733
vtp (interface configuration) vtp (VLAN configuration) vtp primary
APPENDIX
A
cat
2-740
A-4 A-5
delete dir
A-6
A-7
flash_init format
A-9 A-10
fsck
A-11
help
A-12
memory
A-13
mkdir
A-15
more
A-16
rename
A-17
reset
A-18
rmdir
A-19
set
A-1
A-2
copy
A-20
type unset
A-23 A-24
version B
2-739
Cisco Catalyst Blade Switch 3040 for FSC Bootloader Commands boot
APPENDIX
2-738
A-26
Cisco Catalyst Blade Switch 3040 Debug Commands debug authentication debug auto qos
debug dot1x
B-2
B-4
debug backup debug cisp
B-1
B-6 B-7 B-8
debug dtp
B-9
debug eap
B-10
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
xiv
OL-10696-06
Contents
debug etherchannel
B-11
debug ip dhcp snooping
B-12
debug ip verify source packet debug interface
B-14
debug ip igmp filter
B-15
debug ip igmp max-groups debug ip igmp snooping debug lacp
B-16 B-17
B-18
debug lldp packets
B-19
debug mac-notification debug matm
B-20
B-21
debug matm move update debug monitor
B-23
debug mvrdbg
B-24
debug nmsp debug nvram debug pagp
B-13
B-22
B-25 B-26 B-27
debug platform acl
B-28
debug platform backup interface debug platform cisp
B-29
B-30
debug platform cli-redirection main debug platform cpu-queues debug platform dot1x
B-32
B-34
debug platform etherchannel
B-35
debug platform fallback-bridging debug platform forw-tcam debug platform ip dhcp
B-36
B-37
debug platform ip arp inspection
B-38
B-39
debug platform ip igmp snooping debug platform ip multicast debug platform ip unicast debug platform ipc
B-46
debug platform led
B-47
debug platform matm
B-31
B-40
B-42 B-44
B-48
debug platform messaging application
B-49
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
xv
Contents
debug platform phy
B-50
debug platform pm
B-52
debug platform port-asic
B-54
debug platform port-security
B-55
debug platform qos-acl-tcam
B-56
debug platform remote-commands
B-57
debug platform resource-manager
B-58
debug platform snmp
B-59
debug platform span
B-60
debug platform supervisor-asic debug platform sw-bridge debug platform tcam
B-63
debug platform udld
B-66
debug platform vlan
B-67
debug pm
B-61
B-62
B-68
debug port-security
B-70
debug qos-manager
B-71
debug spanning-tree
B-72
debug spanning-tree backbonefast debug spanning-tree bpdu
B-75
debug spanning-tree bpdu-opt debug spanning-tree mstp debug spanning-tree switch
B-76
B-77 B-79
debug spanning-tree uplinkfast debug sw-vlan
B-84
debug sw-vlan notification debug sw-vlan vtp
C
B-81
B-82
debug sw-vlan ifs
APPENDIX
B-74
debug udld
B-88
debug vqpc
B-90
B-85
B-86
Cisco Catalyst Blade Switch 3040 for FSC Show Platform Commands show platform acl
C-1
C-2
show platform backup interface show platform configuration
C-4
show platform etherchannel
C-5
C-3
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
xvi
OL-10696-06
Contents
show platform forward
C-6
show platform ip igmp snooping show platform ip multicast
C-8
C-10
show platform ip unicast
C-11
show platform ip unicast vrf compaction show platform ip unicast vrf tcam-label show platform ipc trace show platform layer4op
C-16
C-18
show platform mac-address-table show platform messaging
C-21 C-22
C-23
show platform port-asic
C-24
show platform port-security show platform qos
C-29
C-30
show platform resource-manager show platform snmp counters show platform spanning-tree show platform stp-instance show platform tcam show platform vlan
APPENDIX
D
C-19
C-20
show platform mvr table show platform pm
C-14
C-15
show platform ipv6 unicast
show platform monitor
C-13
C-31
C-33 C-34 C-35
C-36 C-39
Acknowledgments for Open-Source Software
D-1
INDEX
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
xvii
Contents
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
xviii
OL-10696-06
Preface Audience This guide is for the networking professional using the Cisco IOS command-line interface (CLI) to manage the Cisco Catalyst Blade Switch 3040 for Fujitsu Siemens Computers (FSC), referred to as the switch. Before using this guide, you should have experience working with the Cisco IOS commands and the switch software features. Before using this guide, you should have experience working with the concepts and terminology of Ethernet and local area networking.
Note
The Cisco Catalyst Blade Switch 3040 for FSC is referred to as the blade switch in the documentation for the Fujitsu Siemens Computers PRIMERGY BX600 S2 blade server (also referred to as the BX600 system in the blade switch hardware documentation).
Purpose The Layer 3 switch is supported by either the IP base image. The IP base image provides Layer 2+ features including access control lists (ACLs), quality of service (QoS), static routing, and the Routing Information Protocol (RIP). This guide provides the information that you need about the Layer 2 and Layer 3 commands that have been created or changed for use with the switch. For information about the standard Cisco IOS Release 12.2 commands, see the Cisco IOS documentation set available from the Cisco.com home page by selecting Technical Support & Documentation > Cisco IOS Software. This guide does not provide procedures for configuring your switch. For detailed configuration procedures, see the software configuration guide for this release. This guide does not describe system messages you might encounter. For more information, see the system message guide for this release. For documentation updates, see the release notes for this release.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
xix
Preface
Conventions This publication uses these conventions to convey instructions and information: Command descriptions use these conventions: •
Commands and keywords are in boldface text.
•
Arguments for which you supply values are in italic.
•
Square brackets ([ ]) means optional elements.
•
Braces ({}) group required choices, and vertical bars ( | ) separate the alternative elements.
•
Braces and vertical bars within square brackets ([{ | }]) mean a required choice within an optional element.
Interactive examples use these conventions: •
Terminal sessions and system displays are in screen font.
•
Information you enter is in boldface screen font.
•
Nonprinting characters, such as passwords or tabs, are in angle brackets (< >).
Notes, cautions, and warnings use these conventions and symbols:
Note
Caution
Means reader take note. Notes contain helpful suggestions or references to materials not contained in this manual.
Means reader be careful. In this situation, you might do something that could result in equipment damage or loss of data.
Related Publications For more information about the switch, see the Cisco Catalyst Blade Switch 3040 for FSC documentation on Cisco.com. http://www.cisco.com/en/US/products/ps6748/tsd_products_support_series_home.html
Note
Before installing, configuring, or upgrading the switch, see these documents: •
For initial configuration information, see the blade switch configuration and installation instructions in the getting started guide or the “Configuring the Switch with the CLI-Based Setup Program” appendix in the hardware installation guide.
•
For device manager requirements, see the “System Requirements” section in the release notes (not orderable but available on Cisco.com).
•
For upgrade information, see the “Downloading Software” section in the release notes.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
xx
OL-10696-06
Preface
You can order printed copies of documents with a DOC-xxxxxx= number from the Cisco.com sites and from the telephone numbers listed in the “Obtaining Documentation and Submitting a Service Request” section on page xxi. •
Release Notes for the Cisco Catalyst Blade Switch 3040 for FSC, Cisco IOS Release 12.2(37)SE (not orderable but available on Cisco.com)
•
Cisco Catalyst Blade Switch 3040 for FSC System Message Guide (not orderable but available on Cisco.com)
•
Cisco Catalyst Blade Switch 3040 for FSC Software Configuration Guide (not orderable but available on Cisco.com)
•
Cisco Catalyst Blade Switch 3040 for FSC Command Reference (not orderable but available on Cisco.com)
•
Device manager online help (available on the switch)
•
Cisco Catalyst Blade Switch 3040 for FSC Hardware Installation Guide (not orderable but available on Cisco.com)
•
Cisco Catalyst Blade Switch 3040 for FSC Getting Started Guide (order number DOC-7817759=)
•
Regulatory Compliance and Safety Information for the Cisco Catalyst Blade Switch 3040 for FSC (order number DOC-7817760=)
•
Cisco Small Form-Factor Pluggable Modules Installation Notes (order number DOC-7815160=)
•
These compatibility matrix documents are available from this Cisco.com site: http://www.cisco.com/en/US/products/hw/modules/ps5455/products_device_support_tables_list.ht ml – Cisco Gigabit Ethernet Transceiver Modules Compatibility Matrix (not orderable but available
on Cisco.com) – Cisco Small Form-Factor Pluggable Modules Compatibility Matrix (not orderable but available
on Cisco.com) – Compatibility Matrix for 1000BASE-T Small Form-Factor Pluggable Modules (not orderable
but available on Cisco.com)
Obtaining Documentation and Submitting a Service Request For information on obtaining documentation, submitting a service request, and gathering additional information, see the monthly What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at: http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS version 2.0.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
xxi
Preface
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
xxii
OL-10696-06
CH A P T E R
1
Using the Command-Line Interface The switch is supported by Cisco IOS software. This chapter describes how to use the switch command-line interface (CLI) to configure software features. •
For a complete description of the commands that support these features, see Chapter 2, “Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands.”
•
For information on the bootloader commands, see Appendix A, “Cisco Catalyst Blade Switch 3040 for FSC Bootloader Commands.”
•
For information on the debug commands, see Appendix B, “Cisco Catalyst Blade Switch 3040 Debug Commands.”
•
For information on the show platform commands, see Appendix C, “Cisco Catalyst Blade Switch 3040 for FSC Show Platform Commands.”
•
For more information on Cisco IOS Release 12.2, see the Cisco IOS Release 12.2 Command Summary.
•
For task-oriented configuration steps, see the software configuration guide for this release.
In this document, IP refers to IP version 4 (IPv4) unless there is a specific reference to IP version 6 (IPv6).
CLI Command Modes This section describes the CLI command mode structure. Command modes support specific Cisco IOS commands. For example, the interface interface-id command only works when entered in global configuration mode. These are the main command modes for the switch: •
User EXEC
•
Privileged EXEC
•
Global configuration
•
Interface configuration
•
Config-vlan
•
VLAN configuration
•
Line configuration
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
1-1
Chapter 1
Using the Command-Line Interface
CLI Command Modes
Table 1-1 lists the main command modes, how to access each mode, the prompt you see in that mode, and how to exit that mode. The prompts listed use the default name Switch. Table 1-1
Command Modes Summary
Command Mode
Access Method
Prompt
Exit or Access Next Mode
User EXEC
This is the first level of access.
Switch>
Enter the logout command.
Privileged EXEC
(For the switch) Change terminal settings, perform basic tasks, and list system information.
To enter privileged EXEC mode, enter the enable command.
From user EXEC mode, enter the Switch# enable command.
To exit to user EXEC mode, enter the disable command. To enter global configuration mode, enter the configure command.
Global configuration
From privileged EXEC mode, enter the configure command.
Switch(config)#
To exit to privileged EXEC mode, enter the exit or end command, or press Ctrl-Z. To enter interface configuration mode, enter the interface configuration command.
Interface configuration
Config-vlan
From global configuration mode, Switch(config-if)# specify an interface by entering the interface command followed by an interface identification.
To exit to privileged EXEC mode, enter the end command, or press Ctrl-Z.
Switch(config-vlan)# In global configuration mode, enter the vlan vlan-id command.
To exit to global configuration mode, enter the exit command.
To exit to global configuration mode, enter the exit command.
To return to privileged EXEC mode, enter the end command, or press Ctrl-Z. VLAN configuration
From privileged EXEC mode, enter the vlan database command.
Line configuration
From global configuration mode, Switch(config-line)# specify a line by entering the line command.
Switch(vlan)#
To exit to privileged EXEC mode, enter the exit command. To exit to global configuration mode, enter the exit command. To return to privileged EXEC mode, enter the end command, or press Ctrl-Z.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
1-2
OL-10696-06
Chapter 1
Using the Command-Line Interface CLI Command Modes
User EXEC Mode After you access the device, you are automatically in user EXEC command mode. The EXEC commands available at the user level are a subset of those available at the privileged level. In general, use the user EXEC commands to temporarily change terminal settings, perform basic tests, and list system information. The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt. Switch> ?
Privileged EXEC Mode Because many of the privileged commands configure operating parameters, privileged access should be password-protected to prevent unauthorized use. The privileged command set includes those commands contained in user EXEC mode, as well as the configure privileged EXEC command through which you access the remaining command modes. If your system administrator has set a password, you are prompted to enter it before being granted access to privileged EXEC mode. The password does not appear on the screen and is case sensitive. The privileged EXEC mode prompt is the device name followed by the pound sign (#). Switch#
Enter the enable command to access privileged EXEC mode: Switch> enable Switch#
The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt. Switch# ?
To return to user EXEC mode, enter the disable privileged EXEC command.
Global Configuration Mode Global configuration commands apply to features that affect the device as a whole. Use the configure privileged EXEC command to enter global configuration mode. The default is to enter commands from the management console. When you enter the configure command, a message prompts you for the source of the configuration commands: Switch# configure Configuring from terminal, memory, or network [terminal]?
You can specify either the terminal or NVRAM as the source of configuration commands. This example shows you how to access global configuration mode: Switch# configure terminal Enter configuration commands, one per line.
End with CNTL/Z.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
1-3
Chapter 1
Using the Command-Line Interface
CLI Command Modes
The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt. Switch(config)# ?
To exit global configuration command mode and to return to privileged EXEC mode, enter the end or exit command, or press Ctrl-Z.
Interface Configuration Mode Interface configuration commands modify the operation of the interface. Interface configuration commands always follow a global configuration command, which defines the interface type. Use the interface interface-id command to access interface configuration mode. The new prompt means interface configuration mode. Switch(config-if)#
The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt. Switch(config-if)# ?
To exit interface configuration mode and to return to global configuration mode, enter the exit command. To exit interface configuration mode and to return to privileged EXEC mode, enter the end command, or press Ctrl-Z.
config-vlan Mode Use this mode to configure normal-range VLANs (VLAN IDs 1 to 1005) or, when VTP mode is transparent, to configure extended-range VLANs (VLAN IDs 1006 to 4094). When VTP mode is transparent, the VLAN and VTP configuration is saved in the running configuration file, and you can save it to the switch startup configuration file by using the copy running-config startup-config privileged EXEC command. The configurations of VLAN IDs 1 to 1005 are saved in the VLAN database if VTP is in transparent or server mode. The extended-range VLAN configurations are not saved in the VLAN database. Enter the vlan vlan-id global configuration command to access config-vlan mode: Switch(config)# vlan 2000 Switch(config-vlan)#
The supported keywords can vary but are similar to the commands available in VLAN configuration mode. To display a comprehensive list of commands, enter a question mark (?) at the prompt. Switch(config-vlan)# ?
For extended-range VLANs, all characteristics except the MTU size must remain at the default setting. To return to global configuration mode, enter exit; to return to privileged EXEC mode, enter end. All the commands except shutdown take effect when you exit config-vlan mode.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
1-4
OL-10696-06
Chapter 1
Using the Command-Line Interface CLI Command Modes
VLAN Configuration Mode You can use the VLAN configuration commands to create or modify VLAN parameters for VLAN IDs 1 to 1005. Enter the vlan database privileged EXEC command to access VLAN configuration mode: Switch# vlan database Switch(vlan)#
The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt. Switch(vlan)# ?
To return to privileged EXEC mode, enter the abort VLAN configuration command to abandon the proposed database. Otherwise, enter exit to implement the proposed new VLAN database and to return to privileged EXEC mode. When you enter exit or apply, the configuration is saved in the VLAN database; configuration from VLAN configuration mode cannot be saved in the switch configuration file.
Line Configuration Mode Line configuration commands modify the operation of a terminal line. Line configuration commands always follow a line command, which defines a line number. Use these commands to change terminal parameter settings line-by-line or for a range of lines. Use the line vty line_number [ending_line_number] command to enter line configuration mode. The new prompt means line configuration mode. The following example shows how to enter line configuration mode for virtual terminal line 7: Switch(config)# line vty 0 7
The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt. Switch(config-line)# ?
To exit line configuration mode and to return to global configuration mode, use the exit command. To exit line configuration mode and to return to privileged EXEC mode, enter the end command, or press Ctrl-Z.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
1-5
Chapter 1
Using the Command-Line Interface
CLI Command Modes
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
1-6
OL-10696-06
CH A P T E R
2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands aaa accounting dot1x Use the aaa accounting dot1x global configuration command to enable authentication, authorization, and accounting (AAA) accounting and to create method lists defining specific accounting methods on a per-line or per-interface basis for IEEE 802.1x sessions. Use the no form of this command to disable IEEE 802.1x accounting. aaa accounting dot1x {name | default} start-stop {broadcast group {name | radius | tacacs+} [group {name | radius | tacacs+} ... ] | group {name | radius | tacacs+} [group {name | radius | tacacs+} ... ]} no aaa accounting dot1x {name | default}
Syntax Description
name
Name of a server group. This is optional when you enter it after the broadcast group and group keywords.
default
Use the accounting methods that follow as the default list for accounting services.
start-stop
Send a start accounting notice at the beginning of a process and a stop accounting notice at the end of a process. The start accounting record is sent in the background. The requested-user process begins regardless of whether or not the start accounting notice was received by the accounting server.
broadcast
Enable accounting records to be sent to multiple AAA servers and send accounting records to the first server in each group. If the first server is unavailable, the switch uses the list of backup servers to identify the first server.
group
Specify the server group to be used for accounting services. These are valid server group names: •
name—Name of a server group.
•
radius—List of all RADIUS hosts.
•
tacacs+—List of all TACACS+ hosts.
The group keyword is optional when you enter it after the broadcast group and group keywords. You can enter more than optional group keyword.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
2-1
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands
aaa accounting dot1x
radius
(Optional) Enable RADIUS authorization.
tacacs+
(Optional) Enable TACACS+ accounting.
Defaults
AAA accounting is disabled.
Command Modes
Global configuration
Command History
Release
Modification
12.2(25)SEF2
This command was introduced.
Usage Guidelines
This command requires access to a RADIUS server. We recommend that you enter the dot1x reauthentication interface configuration command before configuring IEEE 802.1x RADIUS accounting on an interface.
Examples
This example shows how to configure IEEE 802.1x accounting: Switch(config)# aaa new-model Switch(config)# aaa accounting dot1x default start-stop group radius
Note
Related Commands
The RADIUS authentication server must be properly configured to accept and log update or watchdog packets from the AAA client.
Command
Description
aaa authentication dot1x
Specifies one or more AAA methods for use on interfaces running IEEE 802.1x.
aaa new-model
Enables the AAA access control model. For syntax information, see the Cisco IOS Security Command Reference, Release 12.2 > Authentication, Authorization, and Accounting > Authentication Commands.
dot1x reauthentication
Enables or disables periodic reauthentication.
dot1x timeout reauth-period
Sets the number of seconds between re-authentication attempts.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
2-2
OL-10696-06
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands aaa authentication dot1x
aaa authentication dot1x Use the aaa authentication dot1x global configuration command to specify the authentication, authorization, and accounting (AAA) method to use on ports complying with the IEEE 802.1x authentication. Use the no form of this command to disable authentication. aaa authentication dot1x {default} method1 no aaa authentication dot1x {default}
Syntax Description
Note
default
Use the listed authentication method that follows this argument as the default method when a user logs in.
method1
Enter the group radius keywords to use the list of all RADIUS servers for authentication.
Though other keywords are visible in the command-line help strings, only the default and group radius keywords are supported.
Defaults
No authentication is performed.
Command Modes
Global configuration
Command History
Release
Modification
12.2(25)SEF2
This command was introduced.
Usage Guidelines
The method argument identifies the method that the authentication algorithm tries in the given sequence to validate the password provided by the client. The only method that is truly IEEE 802.1x-compliant is the group radius method, in which the client data is validated against a RADIUS authentication server. If you specify group radius, you must configure the RADIUS server by entering the radius-server host global configuration command. Use the show running-config privileged EXEC command to display the configured lists of authentication methods.
Examples
This example shows how to enable AAA and how to create an IEEE 802.1x-compliant authentication list. This authentication first tries to contact a RADIUS server. If this action returns an error, the user is not allowed access to the network. Switch(config)# aaa new-model Switch(config)# aaa authentication dot1x default group radius
You can verify your settings by entering the show running-config privileged EXEC command.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
2-3
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands
aaa authentication dot1x
Related Commands
Command
Description
aaa new-model
Enables the AAA access control model. For syntax information, see the Cisco IOS Security Command Reference, Release 12.2 > Authentication, Authorization, and Accounting > Authentication Commands.
show running-config
Displays the current operating configuration. For syntax information, select Cisco IOS Configuration Fundamentals Command Reference, Release 12.2 > File Management Commands > Configuration File Management Commands.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
2-4
OL-10696-06
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands aaa authorization network
aaa authorization network Use the aaa authorization network global configuration command to the configure the switch to use user-RADIUS authorization for all network-related service requests, such as IEEE 802.1x per-user access control lists (ACLs) or VLAN assignment. Use the no form of this command to disable RADIUS user authorization. aaa authorization network default group radius no aaa authorization network default
Syntax Description
default group radius
Defaults
Authorization is disabled.
Command Modes
Global configuration
Command History
Release
Modification
12.2(25)SEF2
This command was introduced.
Usage Guidelines
Use the list of all RADIUS hosts in the server group as the default authorization list.
Use the aaa authorization network default group radius global configuration command to allow the switch to download IEEE 802.1x authorization parameters from the RADIUS servers in the default authorization list. The authorization parameters are used by features such as per-user ACLs or VLAN assignment to get parameters from the RADIUS servers. Use the show running-config privileged EXEC command to display the configured lists of authorization methods.
Examples
This example shows how to configure the switch for user RADIUS authorization for all network-related service requests: Switch(config)# aaa authorization network default group radius
You can verify your settings by entering the show running-config privileged EXEC command.
Related Commands
Command
Description
show running-config
Displays the current operating configuration. For syntax information, select Cisco IOS Configuration Fundamentals Command Reference, Release 12.2 > File Management Commands > Configuration File Management Commands.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
2-5
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands
action
action Use the action access-map configuration command to set the action for the VLAN access map entry. Use the no form of this command to return to the default setting. action {drop | forward} no action
Syntax Description
drop
Drop the packet when the specified conditions are matched.
forward
Forward the packet when the specified conditions are matched.
Defaults
The default action is to forward packets.
Command Modes
Access-map configuration
Command History
Release
Modification
12.2(25)SEF
This command was introduced.
Usage Guidelines
You enter access-map configuration mode by using the vlan access-map global configuration command. If the action is drop, you should define the access map, including configuring any access control list (ACL) names in match clauses, before applying the map to a VLAN, or all packets could be dropped. In access-map configuration mode, use the match access-map configuration command to define the match conditions for a VLAN map. Use the action command to set the action that occurs when a packet matches the conditions. The drop and forward parameters are not used in the no form of the command.
Examples
This example shows how to identify and apply a VLAN access map vmap4 to VLANs 5 and 6 that causes the VLAN to forward an IP packet if the packet matches the conditions defined in access list al2: Switch(config)# vlan access-map vmap4 Switch(config-access-map)# match ip address al2 Switch(config-access-map)# action forward Switch(config-access-map)# exit Switch(config)# vlan filter vmap4 vlan-list 5-6
You can verify your settings by entering the show vlan access-map privileged EXEC command.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
2-6
OL-10696-06
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands action
Related Commands
Command
Description
access-list {deny | permit}
Configures a standard numbered ACL. For syntax information, select Cisco IOS IP Command Reference, Volume 1 of 3:Addressing and Services, Release 12.2 > IP Services Commands.
ip access-list
Creates a named access list. For syntax information, select Cisco IOS IP Command Reference, Volume 1 of 3:Addressing and Services, Release 12.2 > IP Services Commands.
mac access-list extended
Creates a named MAC address access list.
match (class-map configuration)
Defines the match conditions for a VLAN map.
show vlan access-map
Displays the VLAN access maps created on the switch.
vlan access-map
Creates a VLAN access map.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
2-7
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands
archive download-sw
archive download-sw Use the archive download-sw privileged EXEC command to download a new image from a TFTP server to the switch and to overwrite or keep the existing image. archive download-sw {/force-reload | /imageonly | /leave-old-sw | /no-set-boot | /no-version-check | overwrite | /reload | /safe} source-url
Syntax Description
/force-reload
Unconditionally force a system reload after successfully downloading the software image.
/imageonly
Download only the software image but not the HTML files associated with the embedded device manager. The HTML files for the existing version are deleted only if the existing version is being overwritten or removed.
/leave-old-sw
Keep the old software version after a successful download.
/no-set-boot
Do not alter the setting of the BOOT environment variable to point to the new software image after it is successfully downloaded.
/no-version-check
Download the software image without checking the compatibility of the stack protocol version on the image.
/overwrite
Overwrite the software image in flash memory with the downloaded one.
/reload
Reload the system after successfully downloading the image unless the configuration has been changed and not been saved.
/safe
Keep the current software image; do not delete it to make room for the new software image before the new image is downloaded. The current image is deleted after the download.
source-url
The source URL alias for a local or network file system. These options are supported: •
The syntax for the local flash file system on the switch: flash:
•
The syntax for the FTP: ftp:[[//username[:password]@location]/directory]/image-name.tar
•
The syntax for an HTTP server: http://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar
•
The syntax for a secure HTTP server: https://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar
•
The syntax for the Remote Copy Protocol (RCP): rcp:[[//username@location]/directory]/image-name.tar
•
The syntax for the TFTP: tftp:[[//location]/directory]/image-name.tar
The image-name.tar is the software image to download and install on the switch.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
2-8
OL-10696-06
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands archive download-sw
Defaults
The current software image is not overwritten with the downloaded image. Both the software image and HTML files are downloaded. The new image is downloaded to the flash: file system. The BOOT environment variable is changed to point to the new software image on the flash: file system. Image names are case sensitive; the image file is provided in tar format. Compatibility of the stack protocol version on the image to be downloaded is checked with the version on the switch stack.
Command Modes
Privileged EXEC
Command History
Release
Modification
12.2(25)SEF2
This command was introduced.
Usage Guidelines
The /imageonly option removes the HTML files for the existing image if the existing image is being removed or replaced. Only the Cisco IOS image (without the HTML files) is downloaded. Using the /safe or /leave-old-sw option can cause the new image download to fail if there is insufficient flash memory. If leaving the software in place prevents the new image from fitting in flash memory due to space constraints, an error results. If you used the /leave-old-sw option and did not overwrite the old image when you downloaded the new one, you can remove the old image by using the delete privileged EXEC command. For more information, see the “delete” section on page 2-84. Use the /overwrite option to overwrite the image on the flash device with the downloaded one. If you specify the command without the /overwrite option, the download algorithm verifies that the new image is not the same as the one on the switch flash device. If the images are the same, the download does not occur. If the images are different, the old image is deleted, and the new one is downloaded. After downloading a new image, enter the reload privileged EXEC command to begin using the new image, or specify the /reload or /force-reload option in the archive download-sw command.
Examples
This example shows how to download a new image from a TFTP server at 172.20.129.10 and overwrite the image on the switch: Switch# archive download-sw /overwrite tftp://172.20.129.10/test-image.tar
This example shows how to download only the software image from a TFTP server at 172.20.129.10 to the switch: Switch# archive download-sw /imageonly tftp://172.20.129.10/test-image.tar
This example shows how to keep the old software version after a successful download: Switch# archive download-sw /leave-old-sw tftp://172.20.129.10/test-image.tar
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
2-9
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands
archive download-sw
Related Commands
Command
Description
archive tar
Creates a tar file, lists the files in a tar file, or extracts the files from a tar file.
archive upload-sw
Uploads an existing image on the switch to a server.
delete
Deletes a file or directory on the flash memory device.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
2-10
OL-10696-06
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands archive tar
archive tar Use the archive tar privileged EXEC command to create a tar file, list files in a tar file, or extract the files from a tar file. archive tar {/create destination-url flash:/file-url} | {/table source-url} | {/xtract source-url flash:/file-url [dir/file...]}
Syntax Description
/create destination-url flash:/file-url
Create a new tar file on the local or network file system. For destination-url, specify the destination URL alias for the local or network file system and the name of the tar file to create. These options are supported: •
The syntax for the local flash file system: flash:
•
The syntax for the FTP: ftp:[[//username[:password]@location]/directory]/tar-filename.tar
•
The syntax for an HTTP server: http://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar
•
The syntax for a secure HTTP server: https://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar
•
The syntax for the Remote Copy Protocol (RCP) is: rcp:[[//username@location]/directory]/tar-filename.tar
•
The syntax for the TFTP: tftp:[[//location]/directory]/tar-filename.tar
The tar-filename.tar is the tar file to be created. For flash:/file-url, specify the location on the local flash file system from which the new tar file is created. An optional list of files or directories within the source directory can be specified to write to the new tar file. If none are specified, all files and directories at this level are written to the newly created tar file.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference OL-10696-06
2-11
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands
archive tar
/table source-url
Display the contents of an existing tar file to the screen. For source-url, specify the source URL alias for the local or network file system. These options are supported: •
The syntax for the local flash file system: flash:
•
The syntax for the FTP: ftp:[[//username[:password]@location]/directory]/tar-filename.tar
•
The syntax for an HTTP server: http://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar
•
The syntax for a secure HTTP server: https://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar
•
The syntax for the RCP: rcp:[[//username@location]/directory]/tar-filename.tar
•
The syntax for the TFTP: tftp:[[//location]/directory]/tar-filename.tar
The tar-filename.tar is the tar file to display. /xtract source-url flash:/file-url [dir/file...]
Extract files from a tar file to the local file system. For source-url, specify the source URL alias for the local file system. These options are supported: •
The syntax for the local flash file system: flash:
•
The syntax for the FTP: ftp:[[//username[:password]@location]/directory]/tar-filename.tar
•
The syntax for an HTTP server: http://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar
•
The syntax for a secure HTTP server: https://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar
•
The syntax for the RCP: rcp:[[//username@location]/directory]/tar-filename.tar
•
The syntax for the TFTP: tftp:[[//location]/directory]/tar-filename.tar
The tar-filename.tar is the tar file from which to extract. For flash:/file-url [dir/file...], specify the location on the local flash file system into which the tar file is extracted. Use the dir/file... option to specify an optional list of files or directories within the tar file to be extracted. If none are specified, all files and directories are extracted.
Defaults
There is no default setting.
Cisco Catalyst Blade Switch 3040 for FSC Command Reference
2-12
OL-10696-06
Chapter 2
Cisco Catalyst Blade Switch 3040 for FSC Cisco IOS Commands archive tar
Command Modes
Privileged EXEC
Command History
Release
Modification
12.2(25)SEF2
This command was introduced.
Usage Guidelines
Filenames and directory names are case sensitive. Image names are case sensitive.
Examples
This example shows how to create a tar file. The command writes the contents of the new-configs directory on the local flash device to a file named saved.tar on the TFTP server at 172.20.10.30: Switch# archive tar /create tftp:172.20.10.30/saved.tar flash:/new-configs
This example shows how to display the contents of the file that is in flash memory. The contents of the tar file appear on the screen: Switch# archive tar /table flash:.tar info (219 bytes) / (directory) (610856 bytes) /info (219 bytes) info.ver (219 bytes)
This example shows how to display only the /html directory and its contents: Switch# archive tar /table flash:.tar /html /html/ (directory) /html/const.htm (556 bytes) /html/xhome.htm (9373 bytes) /html/menu.css (1654 bytes)